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1\ #E— project

@& Quartus 11 = O X
CFile | Edit View Project Assignments Processing Tools Window Help

o e N o || s 2w 80> w00k & ®|u|o|

= Open... Ctrl+0

Close Ctrl+F4

=

[# Open Project... Ctrl+]
Convert MAX+PLUS Il Project...
Save Project

Close Project

= save Ctrl+S
Save As...
Save Current Report Section As...

Eile Properties...

Create [ Update L
Export..

Convert Programming Files...

W Page Setup... ——

[& Print Preview S @ ViewQuartusii
i Information

& print... Ctrl+P

Recent Files 4 ® Documentation

Recent Projects |

Exit Alt+F4

Syslem}i Processing )\ Extra Info )\ Infa )\ wlaming )\ Critical 'w'aming )\ Emar )\ Suppressed )\ Flag f
IMessage il il ILDcaliUn. d Locate |
[ame | Idle NUM 4

Messages
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2. & EprojectilE RN E K H AR MR NextiA 4L

Mew Project Wizard: Directory, Name, Top-Level Entity [page 1 of 5] b

what iz the warking directory for this project?

‘ C:UsershD ongwehD esktophPLD \test] -

wihat iz the name of this project?

test]

wihat iz the name of the top-level dezign entity for thiz project? Thiz name is caze zenzitive and must exactly match the
entity name in the design file.

test]

Uze E xisting Project Settings ...

MNext = Finish ‘ BiE
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3. IR TFE (project)H

, ERRE

7

77N

MNew Project Wizard: Add Files [page 2 of 5]

File name:

File name |Ty'pe lLib. T [Desig:n entr. . . lH:DL version

Select the design files you want to include in the project. Click &dd Al to add all design files in the project directory to
the project. Mote: you can always add design files to the project later.

Add All

s

S pecify the path names of any non-default libraries.

= Back

Uszer Libraries...

Next =

Finish

bl

IREVIBALTS, ENextdfsE
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4, IEFEARTIENEEZRBNFIZHEHEMAXT128SLC84-7

New Project Wizard: Family & Device Settings [page 3 of 5] ¥

Select tHe family and device pou want to target for compilation.

- Device tarmily - - Shaw in ‘Awvailable device' list-
Eamily: ] h&e< 70005 _:__j Package: Any =
]All _j Pin count: Ay !
- Target device = 2pEc il Any =

™ Auto device selected by the Fitter ¥ Show advanced devices

* Specific device selected in 'Available devices' list [~ HardCor

Ayaillable devices:

M ame | Core w... I Macra... | A
N EFM7OB45TC100-7 5.0 B4

P 70G45TCT00-10 5.0 B4
5.0 B4
5.0 B4
5.0 128

EPM71285LC84-10

EPM71285LC84-15 128

EFM71285LI184-10 128

EPM712850C100-6 128

EPM712850C100-7 128

EPM712850C100-10 128

EFPM712850C10015 128 v

| ]
v

« Back MNext = Finish ‘ Biig
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5, iﬁE SRE, hE. FIFSRet, el LIRSS
Roxsile, mABRHEENTIE, :fizNextélié'J-o

Mew Project Wizard: EDA Tool Settings [page 4 of 5]

Specify the other EDA tools - in addition to the Quartus || software - uzed with the project.

Dregign Entry/Synthesiz

Tool

[ R

Sirnulat ]
Toolname:  |<Nores ~|
o | =l
[Z R

Timing Analysiz :
Tool name J M _VJ
Foim I =
"l

f’#éiﬁ«# é-
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6. WESHHSE, #KFinish5TprojectdYE L.

New Project Wizard: Summary [page 5 of 5] x

When you click Finizh, the project will be created with the following settings:

Project directary:

C./Users/Dongwei/Desktop/PLD ftest] /

Froject name: test]
Top-level design entity: testl
Mumber of files added: 1]
Mumber of uzer libraries added: ]

Device assignments:

Family name: MA70005

Device: EPM71285LC84-7
EDA tools:

Design entry/synthesis: <Manes

Sirnulation: <Mone:

Timing analyzis: <Mone:

Operating conditions:
Core woltage: 5.0V

Junction temperature rangs: 0-85f2

= Back i

FRBEZLLXS

University of Science and Technology of China




TR [RIBEMN L RiF

1. File ->new, 1&FEFTE—/BDFX &

Q Quartus Il - Ci/Users/Dongwei/Desktop/PLD/test]/test] - testl
File | Edit View Project Assignments Processing Tools Window Help

o liest SR,V C TIr D B84 0

= Open... Ctrl+0

Close Ctrl+F4

i2] New Project Wizard...

[E7 Open Project... Ctrl+)
Convert MAX+PLUS Il Project..
Save Project
Close Project

H save Cirl+S
Save As..

Save Current Report Section As...

Eile Properties..

Create / Update »
Export...
Convert Programming Files...

W Page Setup...
[& Print Preview

@ View Quartus I

&) Prirt.. Ctrl+P Information
il ’
Recent Projects. 3 l
Exit Alt+F4

Info

E Message: ﬁl il |Lu.:a|mn | Locate

Create a new document T MW | Idie | [NUM 4

Processing Exhia Info Ciitical Warning Suppressed

10

Mew s
-~ SOPC Builder System A
- Design Files

AHDL File

EDVF File
State Machine File
Systemt'enlog HOL File
Tel Script File
Werilog HOL File
WHOL File
= Memary Files
- Hewadecimal [Intel-Format] File
= Mermaony Initialization File
[=- Werification/Debugging Files
- [n-Spztem Sources and Probes File
- Logic Analyzer Interface File
- SignalT ap |l Logic &nalyzer Fils
- Wector waveform File
[=1- Other Files
- AHOL Include File
- Block Syrmbal File
- Chain Description File
- Sunopsys Design Congtraints File
- Text File

agK I Caticel
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2. #Eirand3 =

Symbol >

Libraries:

= E? & fintelfpgas/s. 0/ quartuz/libre
FE3 megafunctions
9 others
S primitives
o T BT buffer
ii'Iﬂ:;EHE logic:
-EF andl12
-EF and2

and4
-EF andB
b andd
-EF band12
[ 3 £ hand? 5
£ >
5

| Mame.

Gt B

v Eepeat-Mude
[T Inzert spmbol a2 blgek
[T Launch kega 2\%.)\ ang

Megaiwiizard Plug-ln kManager... ‘

0] 4 LCancel ‘
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3, 18 E??T%’T’Ffﬁ:‘\ﬁﬂ input F1 output E i, FHiEzk

B Symbaol >

Libraries:

T E‘ . F & edintelfpga/s.0/quartusdlibrarie
3 , FHEI megafunctions
B _'I' FHE others

-1i— EHEr primitives
GG i T buffer
i

il HEI logic

e HED other

= i pin
5t bide

¢ RER autput
BT storage

B >

Marme:
o B
W Repeat-insert mode

I Inzert sumbol as Bl

~

Megawizard Plug-n Manager...

- 4 ok | Cancel

T TP PR pymprrpr SRR ) - LA

G

i pin_name2
TR T T P P P T T  eT PTP TP EP PP PP rrerep S PRPRE o1 APRTPTPLS
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4. 2 EM®R (k) , ME%kIE

Vb,

Mrewo o[ on %o ® ale

' ] Cluartus 11 >
AN NI NI N NN NS NS AN NI NN NN NN NN I NI NI NN RN l/. -\ L
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5. AIBREMWREG,

) testl.bdf

R R 43 4T

] @ Compilation Report - Flow Summ._. l

Sy 3 Compilation Report

----- =) Legal Motice

----- &R Flow Summary

----- =] BEH Flow Settings

----- = BE Flow Mon-Default Global
----- =] EH Flow Elapsed Time

----- = Flow Log

-5 Analysis & Synthesis
]%D Fitter

F|-&Zh_] Assembler

| oy (Y ey N oy N |

&5 Timing Analyzer

Flow Summary

Flow Status

Quartus IT Version
Revizion Hame

Top—level Entity Hame
Family

Device

Timing Models

Met timing requirements
Total macrocells

Total pins

Successful — Wed Sep 21 19:12:48 2022
8.0 Build 215 05/23,/2008 5] Full Verzien
testl

testl

MASE FO00S

EFM71285LC84—7

Final

Yes

1 /128 (<1 %)

g /68 (12 %)
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6. ECEM, PECEMBIFEEYSIF—IX, Assignments -> Pin Planner
gy & Asmgnments > Assignment Edltor > Category Hi%#¥ Pin

Yoleter AvL Y ¥ YN\ulolcliivieleTeY - NoTete l—% olrecton
e O = inl nput
13 O 7 2 li' in2 III'II:ILIt
" % X = (3 E  in3 lInput
5 (D) H A no|4 £F  out utput
op View _,#U

(O P On |5 TCK Input
’ 8 8 " s B DI Input
Vi )i 7 L TDO Output
2 () A e 8 B TMS Input
2 8 A DYA 8 : ‘xj [+ ::ategury Fin
j g 8 : “-l_] ]ThIE category dlsplays all pin assignments for the target device family. Pin as:
e Ow =
= /é\ MAX7000S % « T Edit X[/ fina
ot EPM7128SLC84-7 e To Location General Function
ER ) O Bk PIN_4 1o
2 O Os (2 E=in2 PIM_5 1jo
2 /] O« (B =in3 PIN_G Ijo

COOOCOACOOVACOONVOOOOOA 4 L out PIMN_B Ijo

I oM OB ¥ ¥ M W SN &M L 43 M4 45 & & 48 & 50 5 8 & 5 :{new}} i{nE',-\'::-:‘:-
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@ Quartus - CflUsers =i /Desktop/PLD /test ftast testl - Db Planrie
File Edit Vie Pro | '-:'-"'in!:lm*.;_

B (I resmor

Iy @ | [ % Export P
IEC Br@: [T teett S e mekmy

— * = B EHEH

= o1 R db 2022/9/21 19:12
it
= "4

=m

F I

5 B

za|| =

2 =N

. B @

A e

= RS ATE s

. ‘

i - Bl Lo
{RTFEEB(T): |Comma Separated Value File (% osv) ﬂ BN
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8. HELTEBIIF—IX

.E| .l.‘-:-m}'-ill.e EI-'.--:i.g.n. Cu:-mpi.le .Desigu
b . ﬁ.nal}rsls d S_:,_l_'n.thes.is
Fitter (Flace & Route) |
Azsembler (Generate programming files)
. E;iassic 'I-'iming ﬁ.ns;l}rsis |

hnalysziz & Symthesis
. 2 s [
Fitter (Flace & Route)

pzzembler (Generate programming files)

Yvvy

ANANESANAN
viviv|y

Clazssic Timing Analw=sis

. (RN, .. T (- S
— ine MPUT ¢ ; :
' =vee+—— )

' '”5t o ﬁ—
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1. File->new, Vector Waveform File, /=7 ok

New *
i SOPLC Builder System A
=8 Dezign Files
- BHDL File
- Black DiaaramdSchematic File
- EDIF File
- State Machine File
- Sustemerlaog HDL File
- Tl Script File
- erlog HOL File
-~ WHOL File
=1~ Memomny Files
Hexadecimal [Intel-Format) File
temary Initialization File
E- Werlication/Debugaging Files
- [n-Spztem Sources and Probes File
- Logic Analyzer Interface File
- SignalT ap Il Logic Analyzer File
---- favetorm File
- Other Files
- BHDOL Include File
- Block, Symbaol File
- Chain Dezcription File
- Synopzys Design Constraints File
- Teut File U

o]

Cancel
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2 FTERTHERKFE M

'I:a Waveforml. ywf

:: Master Time Bar: 2725 ns ~ || Painter:
T k o 1??1112&5 % s ID.Q ns
A : : =
| |
@,
WEE=HX
MNode Find 1 EAs T X
Insert Node or Bus A ey 1. Pt
MNamed: ]" _:] Filter ]F‘ins: assigned _'J Customize... ] List ] 0K ]
Look in: (=41 :_]_J ¥ Include subentities Stoy ] Cancel ]
N arne: I |:| K Mades Found: Selected Nades:
- | Mame ] Assignments | | Hame ] Agsighments { 1
B inl PIN_4 | 5 [testfin PIN_4 |
3 B in2 FIN_5 | B b=t fin2 FIN_G |
l'.-'l:lE-' | INPUT Lj I:ar":EI B in3 FIN_E | B ltest]fin3 PIN_E |
£ out FIN_8 [ ¥ [testTlout PIN_8 (
Yalue type: |E|-Level
»
Badis: |asc - . S| 2. s
IS = B
: 1 T FANA =
Bz width: «
Start indesx: 0
[ Display gray code count az binary count
< > < >
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3. WEHER

A

-

8], Edit->End Time, & & &1&E /98]

End Time

Tirne: ]1 i ] us Lj

- Diefault extension optionz:

Extenzion wvalue; jLast clock pattern

- End time extension per signal: -

=]

o]

SignalMame | Direction | R adix | Estension value |
_inl Input (ASCH | Default extenzion value |
in2_ Input WASCI | Default extension value |

ind. Input |ASCI | Default extension value |
out |Output  |ASC [ Default extenzion value

Cancel

X i
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4. ¥ E Grid Size (Edit-> Grid Size) , M/ERERN G SR

@ | Maszter Time Bar:

Value a P BE
i Fame | 2T
w5 o el b
1 inz Ao |
A o2 in3 ao |
: ‘ 03 out AX
Grid Size > ™y
ar
Baze grid an- == _ - - -
e E el 0 ps EU.Q ns IEIEI.IU ns IED.IU ns ZUU.IU ns
X, Hame Dui-.sat 0 s
~| 0 | * _
‘Tr =0 ini A0
¢ Time period: o . . - in2 AD 1 il
, = | EhxXAE X 2 in3 a0 1
Period: |5|:|.|:| ]ns __:] b in1. in2. in3 &b 3 st | AN
v N2
()4 | Cancel ‘ o
C
_ 1
e
ye
e
AR
L
2

N F¥RBZLLK S
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4.

BfTF{AE, Processing -> Simulator Tool
B Smulfier JFFEmMode ATiming =EE]

Sirnulation rmode: iTiming LI Generate Functional Simulation l'-ie!hr;?l
Sirnulation input: itESH-VWf I Add Multiple Files. . |

- simulaf®n p IR wwi 34, S EnRE

% Fun simulation until all vector stimuli are uzed

™ End simulation at: I'IEIEI ins _:]

Cuartus 1l o |

— Simulation options -
W Automatically a

e

[~ Check outputs s
I Simulatar was successful
[~ Setup and halc

™ Glitch detectior

[~ Owenarite simub
[T Generate Sign:

= e
[ Generate WCD File: I I . . _l

00:00:00

E’_L Start | 40 Stop | l?} Open I ﬂ"_:@ Repart I

W=

W FEAZELKE
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6. mif Report EFFFHELER

nl I A0
inZ A0
in3 A0
out A0

u

iE;ZTF_I

O ¢easLixs

d Technology of Chi
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RF{HE I File -> Save Current Report Section As

& 555

x

FEiRi)
Py
S
I

e

2

[lad==R: &
=
podsg

{RTETEIL): 1 testl

=i

EHE

db

2022/9/21 20x49

ICEBROUAEB LIRS IR EEENIIEHUIEEE

a5 (H)

Jtestl timing. owwf ____1 | 127E(E) I

TRIFZEEIT):

iCnmpressed Vector Waveform File (% cv___J BN

W Add file to cument project

Oteazsas=s

itv of Se nd Technology of Chin;
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i#1TIhEE{AE, Processing -> Simulator Tool

& slizreiE mode 3 Functional

e | = |

Simulation mod Functional Generate Functional Simulation Metlist ]

Simulation nput;

% Fun simulation until all vector stimuli are used

7 End simulation at: ]'IDEI 1ns _VJ

~ Simulation optionz -
¥ Automatically add pins to simulation output waveforms

[T Check outputs g 1
[T Setup and hold tme violation detection
[T Gilitch detection:  |1.0 Ins _J

[~ Owenanite simulation input file with gimulation resulks

Add Multiple Files...

g RS AR v S

[T Gererate Signal Activing File ]
[ Generate VLD File: I
= 00:00:01

=
_J ]

_EI BE %»u%

| Quartus Il

P
|0I Functional Simulation Metlist Generation was successful
- -

E_’L Start ‘j;,‘ Stop @- Open (E‘g Report

25

X 1

| Quartus 1l

L ¥
| Simulator was successful

HEE
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9. Ri Report BEERFHELR

0 ini Lo
1 1ne &0
[ 1 ind A O
£ 3 out A D

I |

:g_m

B
N
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10, RF{AEI File -> Save Current Report Section As

G 555 X L
BIAED: [ testl B = i
# == B xS
HEEIAa] db 202209721 20:51
‘ 1 test1 timing.cvwf 2022/9/21 20:50
£H|
o |
E=
1HEEE. R
.
pedshy o = H- ) Pt et Eal (fm
1D BRSO R XS R L ES RHIhEE RS E
£ >
i (D Jtestl_functi-:nn:al. cvwf _:__1 | {217 (2) |
{%ﬁﬁﬂ(lj ill:-:-mpressed Vector Waveform File (% ov T] Eﬂ,ﬁ
v Add file to curent project
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Quartus MBS (Symbol) FEEERIK#E (Wand3. dffX74138%F)

=2

3. MREMMHENXH (vwh) ZTF—1, FEFINEENEMI
% (FF7%: Assignments - Settings - Simulator Settings - Select simulation

options - Simulation input) . &N, RERKANFEREELZNBMNMIE
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X FE

Project -> Archive Project, i L#EF4E, £ MK.qarBIXHE, SSEERE
—HIR 3,

SEEGIRFZEMLE : http://home.ustc.edu.cn/~dwzou/
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